
 

 

Utility Billing: Best Practices 
 

Submitting Support Tickets 
 

1. MCSJ - Go to Help > Submit Support Ticket. Select the Module you 
need assistance with. Enter a Subject line for the case. Include as 
many details as you can in the allotted space. Specify a priority so we 
can best identify the urgency of your case. Attach up to 4 documents 
for our staff to review prior to contacting our office. Click Submit 
when finished. 

 

   
 

2. EA411.com – If the MCSJ software is open, go to Help > Launch Support 
Site. If the MCSJ program is not open, open a browser and go to 
EA411.com. Once on our website, hover the mouse over Contact, and 
then click Support. Begin entering your contact information, and check 
off your current situation. Select the Module your case is in reference 
to. Enter any case details you would like us to be aware of before we 
contact you. Click Submit when finished. 

3. Support@edmundsassoc.com – Send any support inquiries to our 
support email, with as many case details and attachments as the 
situation may require. 

 
 



 

 
 

4. Live Chat - If the MCSJ software is open, go to Help > Launch Support 
Site. If the MCSJ program is not open, open a browser and go to 
EA411.com. Once on our website, click the Live Chat button on the 
right side of the screen towards the scroll bar. Insert your name, and 
then hit Enter. An operator will then shoot you a message asking how 
we may assist you today. Begin describing your case, our operator will 
do their best to assist you. If a phone call or connection to your 
computer is necessary, one of our representatives will contact you to 
assist with the issue.  
 

 
 
Setting Up Your Workspace 
 

1. Saving your Workspace – Our system has the ability to open pre-
selected MCSJ screens upon logging in to the system. To set up, open 
all Maintenances/Routines/Reports you would like to have open when 
logging into MCSJ. Then go to File > Save Workspace. A message will 
pop up asking if you would like to save the Workspace. Click Yes to 
Save. Now, when you log into MCSJ, those screens will open 
immediately. If you would like to Restore your Workspace without 
logging out and logging back into MCSJ, you can go to File > Restore 
Workspace. This will re-open any screens from your Workspace that 
may have been closed by the user. 
 

2. Setting Favorites – Our system has the ability to save any MCSJ screen 
as a favorite. Once saved, you may simply click Favorites, and select 
the MCSJ screen you would like to open from your list. You may 



 

rename the routine in the list to better match your terminology or 
identify the routine as a certain number step in a procedure. For 
example, you may rename the Payment Window as Cash Register, or 
list the Export Meter Gun Data routine as Meter Reading Step 1. 
Renaming the routines in your Favorites list does not rename the 
routine once it is pulled up.  
 

 
 

3. Window –By clicking on Window, a list of all open screens in MCSJ will 
display below. Clicking on any of the screens in the list will bring it to 
the front of the Workspace so you may resume using it. This is 
beneficial for when you have multiple screens open at once and are 
having difficulty finding the one you need. By clicking the Cascade 
option, all open windows will be moved to the top left corner of the 
screen, overlapping in a Cascading fashion. Close All will close all open 
routines on your Workspace. Open All will open all screens that may 
have been minimized. Minimize all will Minimize all open routines to 
the bottom of the Workspace.  



 

 
 
 

Hyperlinks 
 

1. Our system has the ability to pull up information referenced in other 
Maintenances from the current screen using Hyperlinks. If you see an 
identifier underlined on the screen, that is an indication that this is a 
Hyperlink. Simply click on the Hyperlink and the appropriate 
Maintenance will be pulled up with the accounts information. For 
example, if we are looking at Account 42-0, we see that the Location 
ID is 34. By clicking on the Hyperlink for the Location ID, it pulls up 
Location Maintenance with the information for Location ID 34 filled in.  
 

 
 

One Click Adjustments 
 

1. Our system has the ability to do single line adjustments to Utility 
Accounts from the Utility Account Maintenance screen, instead of 
going through a batch. Pull up the Utility Account to adjust, and go to 
the Balances tab, click the Balances Service tab to be adjusted. 



 

a. For a Billing Adjustment, determine which Bill Year/Period needs 
to be adjusted. Once the amount to be adjusted has been 
determined, either double click on the Billing Amount to be 
adjusted, or Right Click on the Billing Amount, and click Adjust 
this Billing. A Billing Adjustment screen will appear. Enter the 
Bill Code the adjustment will be done with, and the transaction 
date for this adjustment. A Description of the Adjustment can be 
entered if desired. Enter the amount to be adjusted in the Flat 
and or Excess Amount section. (Flat amount references either 
the Flat fee or the Minimum charge for a Bill Code, the Excess 
amount references the amount Billed for usage over the 
Allowance. Entering the amount to be adjusted in either section 
will have the same effect on the bill total, but will potentially 
affect your Billing Register if running with Bill Adjustments 
included.) Enter Positive amounts to increase the Billing, and 
Negative Amounts to decrease the Billing.  

 
b. For a Balance Adjustment, determine which Bill Year/Period 

needs to be adjusted. Once the amount to be adjusted has been 
determined, either double click on the Balance Amount to be 
adjusted, or Right Click on the Balance Amount, and click Adjust 
this Balance. A Balance Adjustment screen will appear. Enter the 
Balance Adjustment Code the adjustment will be done with, and 
the transaction date for this adjustment. A Description of the 
Adjustment can be entered if desired. Enter the amount to be 
adjusted in Adjust Amount section. Enter Positive amounts to 
increase the Balance, and Negative Amounts to decrease the 
Balance.  

 



 

c. For a Penalty Adjustment, determine which Bill Year/Period 
needs to be adjusted. Once the amount to be adjusted has been 
determined, either double click on the Penalty Amount to be 
adjusted, or Right Click on the Penalty Amount, and click Adjust 
this Penalty. A Penalty Adjustment screen will appear. Enter the 
Balance Adjustment Code the adjustment will be done with, and 
the transaction date for this adjustment. A Description of the 
Adjustment can be entered if desired. Enter the amount to be 
adjusted in Adjust Amount section. Enter Positive amounts to 
increase the Penalty, and Negative Amounts to decrease the 
Penalty. You can not create a Penalty Credit through this 
routine.  

 

Additional Tab 
 

1. Setting 3rd Party Notifications – Our system allows you to send 
Delinquent Notices and/or Bills for a Utility Account to a 3rd party. Pull 



 

up a Utility Account and go to the Additional Tab. Towards the bottom 
right hand side there is a section titled Co-applicant. The Co-Applicant 
is able to receive either just Delinquent Notices for this account, or 
Delinquent Notices and Bills. Fill in the information for the 3rd party, 
this will print on the additional Bills/Delinquent Notices.  
 

2. Setting up Direct Withdrawal – If you wish to use our Direct Withdrawal 
routine, any Utility Account that wants to sign up will need its Bank 
Account and Routing Number entered into the Additional Tab. Routing 
Numbers are first entered into Bank DFI Maintenance under System 
Utilities, and then selected from the picklist. The Prenote flag should 
be checked off when the Account is being added to Direct Withdrawal. 
This will allow you to create a Prenote file to send to the bank and 
test the Account before running the regular direct withdrawal routine. 
After the Prenote has been accepted, you may uncheck Prenote. There 
is a routine in Special Routines to uncheck all Prenote flags at once. 
 

   
 

Recalculate a Single Bill 
 

1. Our system gives you the ability to Recalculate a bill for a Single Utility 
Account (This routine does not allow you to calculate a bill for a single 



 

account, that can only be accomplished through Bill 
Calculation/Update).  
 

a. First, identify why the account needs to be recalculated. If there 
was a Meter Reading for the Account entered in error, you may 
need to first use the Meter Reading Adjustment Routine to edit 
or delete the incorrect reading. If the wrong Bill Code or Bill 
Code Units was assigned to the Accounts, then these need to be 
edited on the Service Tabs of Utility Account Maintenance. 
 

b. Once the Utility Account has been corrected, go to the General 
Tab of Utility Account Maintenance and click the Recalculate Bill 
button. Select the Service Type and Bill Year/Period to 
Recalculate.  
 

 
 

c. Once selected, a screen will display with the Calculation results. 
The old calculation will display on the left side of the screen, 
and the new Calculation will display on the right. Verify the 
totals, if the Calculation is correct, click Update. The Account 
will now display the Recalculated Bill total.  
 

 
 

 
 



 

Utility Reports 
 

1. Utility Account Status Report – Billing/Collections > Utility Billing > 
Utility Reports > Account Status. This report provides account service 
type balances as of a specified date. It is recommended that this 
report be run monthly, as it will provide a summary of the different 
types of activity (payments, adjustments, billings, etc.) during the 
month. It can be used to ensure the proper Journal Entries and 
Transactions have been recorded in the Finance system, and can also 
be used to reconcile monthly Utility activity. The best way to run this 
report is with no Bill Year/Period Range, the date range set to the 1st 
day of the month to the last date of the month. Check off all Service 
Types, and leave the Status set to Both. Determine whether you want 
to run the Report as type Detail, Condensed, or Totals Only. The Totals 
page will print at the bottom of each Report Type.  
 

 
 

2. Payment Cash Receipts Report – Billing/Collections > Payments > 
Payment Cash Receipts Report. This report allows you to print any 
receipts and/or reversal history between a give date range. We can 
adjust the report parameters to only include Utility totals. Set the 
date range set to the 1st day of the month to the last date of the 
month. Towards the bottom right, unselect all the Payment Types 



 

besides your Utility Service types. This report can be printed to the 
printer, the screen, or excel.  

 
 

3. Utility Unapplied Overpayment List – Billing/Collections > Utility 
Billing > Utility Reports > Unapplied Overpayments List. This report is 
designed to show all Overpayments associated with Utility Accounts 
that were unapplied as of a certain date. (Overpayments and Credits 
are tracked differently in our system. Overpayments are credits not 
assigned to a Year/Period. They are created when a Payment greater 
than the balance due is made on a Utility Account. Credits are 
assigned to a Year/Period and are often created by 
Billing/Balance/Penalty Type adjustments to the Utility Account.) 
Type in the Unapplied As of Date, and check off the Service Types to 
include. Click Print, this report can be generated to the Printer, the 
Screen, or to Excel.  



 

 
 

4. Credit Balance Report – Billing/Collections > Utility Billing > Utility 
Reports > Credit Balance Report. This report is designed to show all 
Accounts with an overall credit balance for a selected Bill/Year period 
as of the Date Range end date. If Include Prior Year/Prds in Balance is 
checked off, any prior year/period balances will be added to the 
accumulated account balance. The Year/Period Range may be blanked 
out to include all year/periods. Leave the Balance Less Than section 
blank or enter a negative number, only accounts with a credit balance 
less than this amount will print. Both Credits and Overpayments are 
taken into consideration when running the report.  
 

 



 

5. Meter Exception Report – Billing/Collections > Utility Billing > Meter 
Reading > Meter Exception Report. This report is actually six reports in 
one. Each of the reports help to identify potential reading and usage 
issues to be reviewed prior to billing. The report also contains an 
option to auto-generate work orders for any accounts that meet the 
report selection criteria. 

a. Tripped Meter – shows accounts that have negative usage and/or 
accounts that have a previous reading that is higher than the 
subsequent reading. 

b. No Readings – shows accounts that have no readings in the 
year/period range selected. 

c. Consecutive Estimates – designed to identify accounts that have 
estimated reads for a specified number of periods. 

d. Zero Usage – shows accounts where the previous read equals the 
current read. 

e. Variance – will compare the usage between two selected 
year/periods. Variance % levels can be entered to only show 
accounts where usage exceeds or falls between certain 
percentages.  
 

 


